前の記事の続きです。
まだ、下図のエラーが表示されます。

NotSupportedException

"NotSupportedException" でググると、Java EE 6 の API のようなので、「プロジェクト・プロパティ」で[Java EE 6 APIライブラリ]を追加するとエラーは消えました。

Java-EE-6-API

まあ、こんなもんで良いのでは...